summaryrefslogtreecommitdiff
path: root/Biz/Dragons.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Dragons.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Dragons.nix')
-rw-r--r--Biz/Dragons.nix15
1 files changed, 4 insertions, 11 deletions
diff --git a/Biz/Dragons.nix b/Biz/Dragons.nix
index 6473232..2530572 100644
--- a/Biz/Dragons.nix
+++ b/Biz/Dragons.nix
@@ -1,14 +1,7 @@
-{ options
-, lib
-, config
-, pkgs
-, ...
-}:
+{ options, lib, config, pkgs, ... }:
-let
- cfg = config.services.dragons;
-in
-{
+let cfg = config.services.dragons;
+in {
options.services.dragons = {
enable = lib.mkEnableOption "Enable the dragons service";
port = lib.mkOption {
@@ -55,7 +48,7 @@ in
"DEPO=${cfg.depo}"
"KEEP=${cfg.keep}"
];
- EnvironmentFile="/run/dragons/env";
+ EnvironmentFile = "/run/dragons/env";
KillSignal = "INT";
Type = "simple";
Restart = "on-abort";