summaryrefslogtreecommitdiff
path: root/Biz/Dragons/Analysis.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Dragons/Analysis.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Dragons/Analysis.nix')
-rw-r--r--Biz/Dragons/Analysis.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/Biz/Dragons/Analysis.nix b/Biz/Dragons/Analysis.nix
index de431a7..49a76e0 100644
--- a/Biz/Dragons/Analysis.nix
+++ b/Biz/Dragons/Analysis.nix
@@ -1,4 +1,4 @@
-{ nixpkgs ? import ../Bild.nix {} }:
+{ nixpkgs ? import ../Bild.nix { } }:
with nixpkgs;
# Run this like so:
#
@@ -12,9 +12,6 @@ bild.image {
fromImage = null;
fromImageName = null;
fromImageTag = "latest";
- contents = [
- bild.pkgs.git
- (bild.run ./Analysis.hs)
- ];
+ contents = [ bild.pkgs.git (bild.run ./Analysis.hs) ];
config.Cmd = [ "/bin/dragons-analyze" ];
}