summaryrefslogtreecommitdiff
path: root/Biz/OsBase.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-01-05 21:55:58 -0500
committerBen Sima <ben@bsima.me>2024-01-06 12:00:09 -0500
commitb43ad79b030aa8a56e786fd363412eb64da2c56b (patch)
tree352ec9c2bf1be5ecda99ba4a1773051e43c13fa3 /Biz/OsBase.nix
parentf86874ef2092ffcd51089b1695cf8aeaa4fb2a0b (diff)
Switch to gnome in beryllium
I couldn't get my monitor to work properly in xmonad, so decided to use gnome for a while because I'll be away and will be using it headless from my macbook anyway.
Diffstat (limited to 'Biz/OsBase.nix')
-rw-r--r--Biz/OsBase.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/Biz/OsBase.nix b/Biz/OsBase.nix
index ffd7258..3b59f11 100644
--- a/Biz/OsBase.nix
+++ b/Biz/OsBase.nix
@@ -2,7 +2,7 @@
let
ports = import ./Cloud/Ports.nix;
in {
- boot.cleanTmpDir = true;
+ boot.tmp.cleanOnBoot = true;
fonts.fonts = with pkgs; [
google-fonts mononoki source-code-pro fantasque-sans-mono hack-font
fira fira-code fira-code-symbols
@@ -24,8 +24,8 @@ in {
services.fail2ban.ignoreIP = [ ports.bensIp ]; # my home IP
services.openssh.enable = true;
services.openssh.openFirewall = true;
- services.openssh.forwardX11 = true;
- services.openssh.passwordAuthentication = false;
- services.openssh.permitRootLogin = "prohibit-password";
+ services.openssh.settings.X11Forwarding = true;
+ services.openssh.settings.PasswordAuthentication = false;
+ services.openssh.settings.PermitRootLogin = "prohibit-password";
system.autoUpgrade.enable = false; # 'true' breaks our nixpkgs pin
}