summaryrefslogtreecommitdiff
path: root/Biz/OsBase.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/OsBase.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/OsBase.nix')
-rw-r--r--Biz/OsBase.nix18
1 files changed, 12 insertions, 6 deletions
diff --git a/Biz/OsBase.nix b/Biz/OsBase.nix
index 3b59f11..50899d2 100644
--- a/Biz/OsBase.nix
+++ b/Biz/OsBase.nix
@@ -1,14 +1,20 @@
-{pkgs, ...}:
-let
- ports = import ./Cloud/Ports.nix;
+{ pkgs, ... }:
+let ports = import ./Cloud/Ports.nix;
in {
boot.tmp.cleanOnBoot = true;
fonts.fonts = with pkgs; [
- google-fonts mononoki source-code-pro fantasque-sans-mono hack-font
- fira fira-code fira-code-symbols
+ google-fonts
+ mononoki
+ source-code-pro
+ fantasque-sans-mono
+ hack-font
+ fira
+ fira-code
+ fira-code-symbols
];
networking.firewall.allowPing = true;
- nix.settings.substituters = [ "https://cache.nixos.org" ]; # "ssh://dev.simatime.com" ];
+ nix.settings.substituters =
+ [ "https://cache.nixos.org" ]; # "ssh://dev.simatime.com" ];
nix.gc.automatic = true;
nix.gc.dates = "Sunday 02:15";
nix.optimise.automatic = true;