summaryrefslogtreecommitdiff
path: root/Biz/Que.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-08 16:02:03 -0400
committerBen Sima <ben@bsima.me>2024-04-10 19:56:46 -0400
commitaa5f12a5a2365a35f17becc66cf7a67fa86a4440 (patch)
treee43c059973558ea0b1687525e00789c353491460 /Biz/Que.nix
parent544d75a47e85d2b334267a43ba065bb69538ad75 (diff)
Reorganize and update nixpkgs upstreams
This patch does a few things: 1. Switches from nixpkgs-unstable to nixos-unstable{,-small}, simply because nixpkgs-unstable is not in cache.nixos.org, but nixos-unstable is, and -small is the same but requires all tests to pass. So we should prefer nixos-unstable-small, whenever possible. 2. Reorganizes the nixpkgs import code such that Nixpkgs.nix returns an attrset of all the nixpkgs that I want to use, rather than putting other nixpkgs branches into the main one as an overlay. This is much simpler and explicit, but it meant I had to change a lot of usages throughtout the nix codebase. 3. As a consequence of 2, moves the overlays into separate files so they can be re-used across nixpkgs branches.
Diffstat (limited to 'Biz/Que.nix')
-rw-r--r--Biz/Que.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/Biz/Que.nix b/Biz/Que.nix
index ac89a56..6971914 100644
--- a/Biz/Que.nix
+++ b/Biz/Que.nix
@@ -1,5 +1,4 @@
-{ nixpkgs ? import ./Bild.nix { } }:
-with nixpkgs;
+{ bild ? import ./Bild.nix { } }:
# The production server for que.run
@@ -28,7 +27,7 @@ bild.os {
defaultGateway = "157.245.224.1";
defaultGateway6 = "2604:a880:2:d1::1";
dhcpcd.enable = false;
- usePredictableInterfaceNames = lib.mkForce true;
+ usePredictableInterfaceNames = bild.lib.mkForce true;
interfaces = {
eth0 = {
ipv4.addresses = [