summaryrefslogtreecommitdiff
path: root/Biz/Users.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Users.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Users.nix')
-rw-r--r--Biz/Users.nix60
1 files changed, 0 insertions, 60 deletions
diff --git a/Biz/Users.nix b/Biz/Users.nix
deleted file mode 100644
index b214704..0000000
--- a/Biz/Users.nix
+++ /dev/null
@@ -1,60 +0,0 @@
-{ config, lib, ... }:
-
-let
- readKeys = k:
- lib.trivial.pipe k [
- builtins.readFile
- (lib.strings.splitString "\n")
- (lib.filter (s: s != ""))
- ];
-in {
- users.groups = {
- # group for publishing web data
- "www-data" = { };
- };
- users.motd = ''
-
- welcome to the simatime network!
- your host is '${config.networking.hostName}'
-
- '';
- users.mutableUsers = false;
- users.users = {
- # bots
- #
- deploy = {
- isNormalUser = true;
- home = "/home/deploy";
- openssh.authorizedKeys.keys = readKeys ./Keys/Deploy.pub;
- extraGroups = [ "wheel" ];
- };
- #
- # humans
- #
- root.openssh.authorizedKeys.keys = readKeys ./Keys/Ben.pub;
-
- ben = {
- description = "Ben Sima";
- isNormalUser = true;
- home = "/home/ben";
- openssh.authorizedKeys.keys = readKeys ./Keys/Ben.pub;
- extraGroups = [ "wheel" "docker" "bitcoind-mainnet" "git" ];
- hashedPassword =
- "$6$SGhdoRB6DhWe$elW8RQE1ebe8JKf1ALW8jGZTPCyn2rpq/0J8MV/A9y8qFMEhA.Z2eiexMgptohZAK5kcGOc6HIUgNzJqnDUvY.";
- };
- dre = {
- description = "Andres Ulloa";
- isNormalUser = true;
- home = "/home/dre";
- openssh.authorizedKeys.keys = readKeys ./Keys/Dre.pub;
- extraGroups = [ "wheel" "git" ];
- };
- nick = {
- description = "Nick Sima";
- isNormalUser = true;
- home = "/home/nick";
- openssh.authorizedKeys.keys = readKeys ./Keys/Nick.pub;
- extraGroups = [ "docker" "git" ];
- };
- };
-}