summaryrefslogtreecommitdiff
path: root/Com/Simatime/Cloud/git.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-02 23:45:04 -0700
committerBen Sima <ben@bsima.me>2020-04-02 23:45:04 -0700
commit65c2b30a288385cf3df4027d50080ac595bbcf83 (patch)
tree391aa2ea046935e4bd5463abf8979633697b99f5 /Com/Simatime/Cloud/git.nix
parent4ef954f7b3e9b5d99d1030843c2633dbd76f37c0 (diff)
Reorganize and comment some of the nix code
Diffstat (limited to 'Com/Simatime/Cloud/git.nix')
-rw-r--r--Com/Simatime/Cloud/git.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/Com/Simatime/Cloud/git.nix b/Com/Simatime/Cloud/git.nix
new file mode 100644
index 0000000..4cdaa28
--- /dev/null
+++ b/Com/Simatime/Cloud/git.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }:
+
+{
+ services = {
+ gitolite = {
+ enable = true;
+ enableGitAnnex = true;
+ # TODO: change this to /var/lib/gitolite?
+ dataDir = "/srv/git";
+ user = "git";
+ group = "git";
+ extraGitoliteRc = ''
+ $RC{SITE_INFO} = 'a computer is a bicycle for the mind.';
+ '';
+ adminPubkey = builtins.readFile ../keys/ben.pub;
+ };
+ };
+}