summaryrefslogtreecommitdiff
path: root/Com/Simatime/buildHaskellApp.nix
diff options
context:
space:
mode:
authorDavid Johnson <djohnson.m@gmail.com>2020-01-30 12:28:03 -0500
committerDavid Johnson <djohnson.m@gmail.com>2020-01-30 12:28:03 -0500
commit491c84bd48646be5a80e3b23cfc356141b1ba9cb (patch)
tree6327ef0a57daa37dd8f62227feb10f8b95c436ca /Com/Simatime/buildHaskellApp.nix
parent73e9789ee4b912063835eb8a40bee7b0f1162000 (diff)
Add clay source, add dontCheck to wai-middleware, clay.
Diffstat (limited to 'Com/Simatime/buildHaskellApp.nix')
-rw-r--r--Com/Simatime/buildHaskellApp.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/Com/Simatime/buildHaskellApp.nix b/Com/Simatime/buildHaskellApp.nix
index 853487d..c7bdd1f 100644
--- a/Com/Simatime/buildHaskellApp.nix
+++ b/Com/Simatime/buildHaskellApp.nix
@@ -18,9 +18,17 @@ let
depsToPackageSet = packageSet: deps:
map (s: builtins.getAttr s packageSet) deps;
+ claySrc = pkgs.fetchFromGitHub {
+ owner = "sebastiaanvisser";
+ repo = "clay";
+ rev = "cc7729b1b42a79e261091ff7835f7fc2a7ae3cee";
+ sha256 = "1vd67976lvi5l4qq18zy6j44apynkl44ps04p8vwfx4gzr895dyp";
+ };
+
ghc865_ = pkgs.haskell.packages.ghc865.override (oldAttrs: {
overrides = with pkgs.haskell.lib; self: super: {
- clay = dontCheck super.clay;
+ clay = self.callCabal2nix "clay" claySrc {};
+ wai-middleware-metrics = dontCheck super.wai-middleware-metrics;
};
});
@@ -30,7 +38,7 @@ let
# ghcjs-8.6.0.1
ghcjs_ = pkgs.haskell.packages.ghcjs.override (oldAttrs: {
overrides = with pkgs.haskell.lib; self: super: {
- clay = dontCheck super.clay;
+ clay = dontCheck (self.callCabal2nix "clay" claySrc {});
http-types = dontCheck super.http-types;
tasty-quickcheck = dontCheck super.tasty-quickcheck;
scientific = dontCheck super.scientific; # takes forever