summaryrefslogtreecommitdiff
path: root/Com/Simatime/users.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-11-06 22:21:48 -0800
committerBen Sima <ben@bsima.me>2019-11-06 22:21:48 -0800
commit376430ca3f4065b35e97f97ed4aaa4062db41440 (patch)
tree631d52ca097f2b859ace29e8c090138f2b81624e /Com/Simatime/users.nix
parent7198d79be4d7d0040d768f395f11b19b05622a8d (diff)
add a common buildOS function with preliminary vpn
Diffstat (limited to 'Com/Simatime/users.nix')
-rw-r--r--Com/Simatime/users.nix57
1 files changed, 26 insertions, 31 deletions
diff --git a/Com/Simatime/users.nix b/Com/Simatime/users.nix
index daac9d6..c951c8e 100644
--- a/Com/Simatime/users.nix
+++ b/Com/Simatime/users.nix
@@ -1,33 +1,28 @@
-{ ... }:
-
-let
- key = f: builtins.readFile (./keys/. + ("/" + f));
-in
-{
- users = {
- users = {
- # bots
- deploy = {
- isNormalUser = true;
- home = "/home/deploy";
- openssh.authorizedKeys.keys = [ (key "deploy.pub") ];
- extraGroups = [ "wheel" ];
- };
-
- # humans
- root.openssh.authorizedKeys.keys = [ (key "ben.pub") ];
- ben = {
- isNormalUser = true;
- home = "/home/ben";
- openssh.authorizedKeys.keys = [ (key "ben.pub") ];
- extraGroups = [ "wheel" "networkmanager" "docker" ];
- };
- nick = {
- isNormalUser = true;
- home = "/home/nick";
- openssh.authorizedKeys.keys = [ (key "nick.pub") ];
- extraGroups = [ "docker" ];
- };
- };
+{ #
+ # bots
+ #
+ deploy = {
+ isNormalUser = true;
+ home = "/home/deploy";
+ openssh.authorizedKeys.keyFiles = [ ./keys/deploy.pub ];
+ extraGroups = [ "wheel" ];
+ };
+ #
+ # humans
+ #
+ root.openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
+ ben = {
+ description = "Ben Sima";
+ isNormalUser = true;
+ home = "/home/ben";
+ openssh.authorizedKeys.keyFiles = [ ./keys/ben.pub ];
+ extraGroups = [ "wheel" "networkmanager" "docker" ];
+ };
+ nick = {
+ description = "Nick Sima";
+ isNormalUser = true;
+ home = "/home/nick";
+ openssh.authorizedKeys.keyFiles = [ ./keys/nick.pub ];
+ extraGroups = [ "docker" ];
};
}