summaryrefslogtreecommitdiff
path: root/Com/Simatime/web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-02 23:45:04 -0700
committerBen Sima <ben@bsima.me>2020-04-02 23:45:04 -0700
commit65c2b30a288385cf3df4027d50080ac595bbcf83 (patch)
tree391aa2ea046935e4bd5463abf8979633697b99f5 /Com/Simatime/web.nix
parent4ef954f7b3e9b5d99d1030843c2633dbd76f37c0 (diff)
Reorganize and comment some of the nix code
Diffstat (limited to 'Com/Simatime/web.nix')
-rw-r--r--Com/Simatime/web.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/Com/Simatime/web.nix b/Com/Simatime/web.nix
deleted file mode 100644
index 22d7199..0000000
--- a/Com/Simatime/web.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ ... }:
-
-let
- bensIp = "73.222.221.62";
-in
-{
- services = {
- nginx = {
- enable = true;
- recommendedGzipSettings = true;
- recommendedOptimisation = true;
- recommendedProxySettings = true;
- recommendedTlsSettings = true;
- virtualHosts = {
- "bsima.me".root = "/home/ben/public_html/";
- "www.bsima.me".root = "/home/ben/public_html/";
- "simatime.com".locations."/".root = "/srv/www/";
- "firefoxsync.simatime.com".locations."/".proxyPass = "http://localhost:5001";
- "hero.simatime.com".locations."/".proxyPass = "http://${bensIp}:3001";
- "tv.simatime.com".locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
- "deluge.simatime.com".locations."/".proxyPass = "http://${bensIp}:8112";
-
- "notebook.simatime.com".locations = {
- "/" = {
- proxyPass = "http://${bensIp}:3099";
- proxyWebsockets = true;
- extraConfig = ''
- proxy_buffering off;
- proxy_read_timeout 86400;
-
- '';
- };
- "/(api/kernels/[^/]+/channels|terminals/websocket)/" = {
- proxyPass = "http://${bensIp}:3099";
- proxyWebsockets = true;
- };
- };
- };
- };
- };
-}