summaryrefslogtreecommitdiff
path: root/Hero/Prod.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-04-15 20:23:35 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:15 -0500
commit7870a19fa4de5a478aec7e071f18cdaaefe7d5f4 (patch)
tree4cd20ef0cef7f5a7559aefc4d1e6b102cca821b3 /Hero/Prod.nix
parent9975f0541df53c0aa4de16d70e8149e00d3973d1 (diff)
Remove required nix arguments
This allows us to use nix-build as a check that bild is working. I think bild sometimes hangs because it doesn't get input from nix-build? I'm not sure, but one workaround is to run nix-build on the target, and then bild will just get the cached build.
Diffstat (limited to 'Hero/Prod.nix')
-rw-r--r--Hero/Prod.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/Hero/Prod.nix b/Hero/Prod.nix
index cc54f95..5b9dde4 100644
--- a/Hero/Prod.nix
+++ b/Hero/Prod.nix
@@ -1,4 +1,6 @@
-{ bild, lib }:
+{ bild ? import ../Biz/Bild/Rules.nix {}
+, nixpkgs ? import ../Biz/Bild/Nixpkgs.nix
+}:
# Production server for herocomics.app
@@ -22,7 +24,7 @@ bild.os {
defaultGateway = "138.68.40.1";
defaultGateway6 = "";
dhcpcd.enable = false;
- usePredictableInterfaceNames = lib.mkForce true;
+ usePredictableInterfaceNames = nixpkgs.lib.mkForce true;
interfaces = {
eth0 = {
ipv4.addresses = [