summaryrefslogtreecommitdiff
path: root/Hero/Service.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-06-27 09:20:59 -0700
committerBen Sima <ben@bsima.me>2020-06-27 09:20:59 -0700
commit14e3c6a61f7727e994c4e1cf2568a3e606f84648 (patch)
tree6322dcfecf06bad2be8f85d560fd81e5206262e2 /Hero/Service.nix
parent1ad6b3248f788cc178162bac5919c0b0fd6f9d39 (diff)
hero: implement the basics of user logins
There's also a lot of refactoring/renaming in here, so the diff is really messy. The overall problem is that I've only ever added code, I've never gone back and reorganized/rearchitected stuff. So adding even small features is becoming an enormous effort. Anyway, this adds the basics of user auth. Next I need to add the auth checks for every route that needs it, and make sure everything is back to working correctly.
Diffstat (limited to 'Hero/Service.nix')
-rw-r--r--Hero/Service.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/Hero/Service.nix b/Hero/Service.nix
index a3c6bd5..e5d811b 100644
--- a/Hero/Service.nix
+++ b/Hero/Service.nix
@@ -31,6 +31,11 @@ in
type = lib.types.package;
description = "herocomics-client package to use";
};
+ skey = lib.mkOption {
+ type = lib.types.path;
+ default = "/run/hero/skey";
+ description = "where to store the signing key";
+ };
domain = lib.mkOption {
type = lib.types.str;
default = "herocomics.app";