summaryrefslogtreecommitdiff
path: root/Omni/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-02 07:36:15 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:08:04 -0500
commitb3e113d2e1351ea1d48170a3433c2228ac2ae137 (patch)
treefa382c41ac2dccece918c8f759bc8fcc6b1fad52 /Omni/Bild.nix
parent442c0702502cae3ac4d7acd09f05635ec8378b06 (diff)
Package ludic
This required upgrading to python 3.12 because of some f-string format thing that ludic uses. It's kind of annoying but the upgrade was easy enough, so I just did it.
Diffstat (limited to 'Omni/Bild.nix')
-rw-r--r--Omni/Bild.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/Omni/Bild.nix b/Omni/Bild.nix
index 6dd6e9d..90fa979 100644
--- a/Omni/Bild.nix
+++ b/Omni/Bild.nix
@@ -7,7 +7,7 @@ let
stable = let stable = nixpkgs.nixos-24_05;
in {
inherit (stable)
- sources lib makeWrapper ccacheStdenv haskell sbcl python3 nixos mkShell
+ sources lib makeWrapper ccacheStdenv haskell sbcl python312 nixos mkShell
dockerTools pkgs;
stdenv = stable.ccacheStdenv;
};
@@ -82,9 +82,9 @@ let
python = {
packages = self.lib.attrsets.getAttrs (import ./Bild/Deps/Python.nix)
- stable.python3.pkgs;
- pythonWith = stable.python3.withPackages;
- buildPythonApplication = stable.python3.pkgs.buildPythonApplication;
+ stable.python312.pkgs;
+ pythonWith = stable.python312.withPackages;
+ buildPythonApplication = stable.python312.pkgs.buildPythonApplication;
};
# c packages are just stable, filtered to just the list of deps i want
@@ -97,8 +97,12 @@ let
git-branchless gitlint groff guile hlint indent jq lolcat mypy nixfmt
ormolu pkg-config ripgrep rustc tree wemux;
llama-cpp = unstable.llama-cpp;
- llm = python3.withPackages
- (p: [ p.llm p.llm-ollama p.llm-sentence-transformers ]);
+ # can't put this in the dev namespace because it pulls in openai with
+ # python311, which conflicts with any other usage of openai with
+ # python312. so i need to make a target that exposese/wraps llm like i did
+ # with llamacpp
+ #llm = python311.withPackages
+ # (p: [ p.llm p.llm-ollama p.llm-sentence-transformers ]);
ollama = unstable.ollama;
ruff = unstable.ruff;
shellcheck = unstable.shellcheck;
@@ -215,7 +219,6 @@ let
gitlint
jq
lolcat
- llm
ormolu
ripgrep
tree