summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Omni/Bild/Deps.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Omni/Bild/Deps.nix')
-rw-r--r--Omni/Bild/Deps.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/Omni/Bild/Deps.nix b/Omni/Bild/Deps.nix
new file mode 100644
index 0000000..9ba0b31
--- /dev/null
+++ b/Omni/Bild/Deps.nix
@@ -0,0 +1,45 @@
+_self: super:
+
+{
+ # Needs upgrading for guile 3
+ # inspekt3d = super.callPackage ./Deps/inspekt3d.nix {};
+
+ guix = super.pkgs.stdenv.mkDerivation rec {
+ pname = "guix";
+ name = "${pname}-${version}";
+ version = super.sources.guix.version;
+ src = super.sources.guix;
+ buildInputs = with super.pkgs; [
+ guile
+ # guile-gcrypt
+ # guile-sql
+ # guile-zlib
+ # guile-lzlib
+ # guile-avahi
+ # guile-git
+ # guile-json
+ gnutls
+ gnumake
+ sqlite
+ libgcrypt
+ gcc
+ ];
+ };
+
+ llm = super.overrideSrc super.llm super.sources.llm;
+
+ nostr-rs-relay = super.callPackage ./Deps/nostr-rs-relay.nix { };
+
+ ollama = super.ollama.override { acceleration = "cuda"; };
+
+ # https://github.com/NixOS/nixpkgs/issues/317147#issuecomment-2147343125
+ radicale = super.radicale.overrideAttrs (_old: rec {
+ version = "3.2.0";
+ src = super.fetchFromGitHub {
+ owner = "Kozea";
+ repo = "Radicale";
+ rev = "v${version}";
+ hash = "sha256-RxC8VOfdTXJZiAroDHTKjJqGWu65Z5uyb4WK1LOqubQ=";
+ };
+ });
+}