summaryrefslogtreecommitdiff
path: root/Omni/Bild/Python.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-02 07:36:15 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:08:04 -0500
commitb3e113d2e1351ea1d48170a3433c2228ac2ae137 (patch)
treefa382c41ac2dccece918c8f759bc8fcc6b1fad52 /Omni/Bild/Python.nix
parent442c0702502cae3ac4d7acd09f05635ec8378b06 (diff)
Package ludic
This required upgrading to python 3.12 because of some f-string format thing that ludic uses. It's kind of annoying but the upgrade was easy enough, so I just did it.
Diffstat (limited to 'Omni/Bild/Python.nix')
-rw-r--r--Omni/Bild/Python.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/Omni/Bild/Python.nix b/Omni/Bild/Python.nix
index 6e4f390..23e9ecd 100644
--- a/Omni/Bild/Python.nix
+++ b/Omni/Bild/Python.nix
@@ -1,17 +1,24 @@
_self: super: {
- python3 = super.python3.override {
+ python312 = super.python312.override {
packageOverrides = _pyself: pysuper:
- with pysuper.pkgs.python3Packages;
+ with pysuper.pkgs.python312Packages;
let dontCheck = p: p.overridePythonAttrs (_: { doCheck = false; });
in {
interegular = callPackage ./Deps/interegular.nix { };
- llm-ollama = callPackage ./Deps/llm-ollama.nix { };
- llm-sentence-transformers =
- callPackage ./Deps/llm-sentence-transformers.nix { };
+ ludic = callPackage ./Deps/ludic.nix { };
mypy = dontCheck pysuper.mypy;
outlines = callPackage ./Deps/outlines.nix { };
perscache = callPackage ./Deps/perscache.nix { };
tokenizers = dontCheck pysuper.tokenizers;
};
};
+
+ python311 = super.python311.override {
+ packageOverrides = _pyself: pysuper:
+ with pysuper.pkgs.python311Packages; {
+ llm-ollama = callPackage ./Deps/llm-ollama.nix { };
+ llm-sentence-transformers =
+ callPackage ./Deps/llm-sentence-transformers.nix { };
+ };
+ };
}