summaryrefslogtreecommitdiff
path: root/Omni/Bot.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Omni/Bot.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Omni/Bot.nix')
-rw-r--r--Omni/Bot.nix61
1 files changed, 61 insertions, 0 deletions
diff --git a/Omni/Bot.nix b/Omni/Bot.nix
new file mode 100644
index 0000000..934ad9c
--- /dev/null
+++ b/Omni/Bot.nix
@@ -0,0 +1,61 @@
+{ options, lib, config, pkgs, ... }:
+
+let cfg = config.services.omnibot;
+in {
+ options.services.bizbot = {
+ enable = lib.mkEnableOption "Enable the omnibot service";
+ package = lib.mkOption {
+ type = lib.types.package;
+ description = "omnibot package to use";
+ };
+ server = lib.mkOption {
+ type = lib.types.str;
+ description = "server address to connect to";
+ };
+ channel = lib.mkOption {
+ type = lib.types.str;
+ description = "channel to join";
+ };
+ dataDir = lib.mkOption {
+ type = lib.types.str;
+ description = "where omnibot will start it's ii tree";
+ };
+ };
+ config = lib.mkIf cfg.enable {
+ systemd.services = {
+ "omnibot-${cfg.server}-${cfg.channel}-ii" = {
+ wantedBy = [ "multi-user.target" ];
+ path = [ pkgs.ii ];
+ script = ''
+ ${pkgs.ii}/bin/ii ${cfg.dataDir}/irc -s ${cfg.server} -p 6667 -n omnibot
+ '';
+ postStart = ''
+ echo "/join ${cfg.channel}" > ${cfg.dataDir}/irc/${cfg.server}/in
+ '';
+ description = ''
+ omnibot ii tree for ${cfg.server}/${cfg.channel}
+ '';
+
+ };
+ "omnibot-${cfg.server}-${cfg.channel}" = {
+ path = [ cfg.package ];
+ wantedBy = [ "multi-user.target" ];
+ after = [ "omnibot-${cfg.server}-${cfg.channel}-ii.service" ];
+ script = ''
+ tail -f ${cfg.dataDir}/irc/${cfg.server}/${cfg.channel}/out \
+ | ${cfg.package}/bin/omnibot \
+ | tee -a ${cfg.dataDir}/irc/${cfg.server}/${cfg.channel}/in
+ '';
+ description = ''
+ omnibot for ${cfg.server}/${cfg.channel}
+ '';
+ serviceConfig = {
+ KillSignal = "INT";
+ Type = "simple";
+ Restart = "on-abort";
+ RestartSec = "1";
+ };
+ };
+ };
+ };
+}