summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Hub.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-04 15:52:52 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:08:05 -0500
commit81cf94523f5a794e5b0c69dbd9a94619135a23c7 (patch)
tree22544f9d741827ebfe65f73f0202b2b095a09cf8 /Omni/Cloud/Hub.nix
parent47c48abf836f5918120c0550c57d4eda32d3f10e (diff)
Prune unused stuff
This was all dead weight, just delete it and move on.
Diffstat (limited to 'Omni/Cloud/Hub.nix')
-rw-r--r--Omni/Cloud/Hub.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/Omni/Cloud/Hub.nix b/Omni/Cloud/Hub.nix
deleted file mode 100644
index 39bbdd0..0000000
--- a/Omni/Cloud/Hub.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{ lib, pkgs, config, ... }:
-
-let
- ssl = {
- cert = "/var/lib/acme/${config.networking.domain}/fullchain.pem";
- key = "/var/lib/acme/${config.networking.domain}/key.pem";
- };
- ports = import ./Ports.nix;
- mkPlugin = path: settings: {
- plugin = "${pkgs.uhub}/plugins/${path}";
- inherit settings;
- };
- motdFile = pkgs.writeText "motd" ''
- Meshheads write code.
- '';
- rulesFile = pkgs.writeText "rules" ''
- 1. x
- 2. (λx.M)
- 3. (M N)
- 4. Profit.
- '';
-in {
- networking.firewall.allowedUDPPorts = [ ports.meshhub ];
- networking.firewall.allowedTCPPorts = [ ports.meshhub ];
-
- services.uhub = {
- "meshhub" = {
- enable = true;
- enableTLS = false;
- settings = {
- hub_name = "meshhub";
- hub_description = "vaporware is dead. long live vaporware";
- server_port = toString ports.meshhub;
- server_bind_addr = "any";
- max_users = 14; # we only have 14 users in meshheads chat
- tls_private_key = ssl.key;
- tls_certificate = ssl.cert;
- tls_enable = "no";
- tls_require = "no";
- };
- plugins = lib.attrsets.mapAttrsToList mkPlugin {
- #"mod_logging.so" = {
- # file = "/var/log/uhub/meshhub.log";
- #};
- "mod_welcome.so" = {
- motd = "${motdFile}";
- rules = "${rulesFile}";
- };
- "mod_chat_history.so" = {
- history_max = "200";
- history_default = "10";
- history_connect = "5";
- };
- };
- };
- };
-}