summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Omni/Cloud/Networking.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Omni/Cloud/Networking.nix')
-rw-r--r--Omni/Cloud/Networking.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/Omni/Cloud/Networking.nix b/Omni/Cloud/Networking.nix
new file mode 100644
index 0000000..1c1f832
--- /dev/null
+++ b/Omni/Cloud/Networking.nix
@@ -0,0 +1,48 @@
+{ lib, ... }: {
+ # This file was populated at runtime with the networking
+ # details gathered from the active system.
+ networking = {
+ nameservers = [ "8.8.8.8" ];
+ defaultGateway = "143.198.112.1";
+ defaultGateway6 = "2604:a880:400:d0::1";
+ dhcpcd.enable = false;
+ usePredictableInterfaceNames = lib.mkForce false;
+ interfaces = {
+ eth0 = {
+ ipv4.addresses = [
+ {
+ address = "143.198.118.179";
+ prefixLength = 20;
+ }
+ {
+ address = "10.10.0.7";
+ prefixLength = 16;
+ }
+ ];
+ ipv6.addresses = [
+ {
+ address = "2604:a880:400:d0::19f1:7001";
+ prefixLength = 64;
+ }
+ {
+ address = "fe80::a06e:26ff:fee1:941";
+ prefixLength = 64;
+ }
+ ];
+ ipv4.routes = [{
+ address = "143.198.112.1";
+ prefixLength = 32;
+ }];
+ ipv6.routes = [{
+ address = "2604:a880:400:d0::1";
+ prefixLength = 128;
+ }];
+ };
+
+ };
+ };
+ services.udev.extraRules = ''
+ ATTR{address}=="a2:6e:26:e1:09:41", NAME="eth0"
+ ATTR{address}=="f2:4e:52:1a:72:ef", NAME="eth1"
+ '';
+}