summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Znc.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Omni/Cloud/Znc.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Omni/Cloud/Znc.nix')
-rw-r--r--Omni/Cloud/Znc.nix76
1 files changed, 76 insertions, 0 deletions
diff --git a/Omni/Cloud/Znc.nix b/Omni/Cloud/Znc.nix
new file mode 100644
index 0000000..e68ebc7
--- /dev/null
+++ b/Omni/Cloud/Znc.nix
@@ -0,0 +1,76 @@
+/* N.B.: generate znc passwords with 'nix-shell -p znc --command "znc --makepass"'
+
+ - https://wiki.znc.in/Configuration
+*/
+
+{ pkgs, ... }:
+
+{
+ services = {
+ znc = {
+ enable = true;
+ openFirewall = true;
+ modulePackages = with pkgs.zncModules;
+ [
+ #backlog clientaway clientbuffer
+ #ignore
+ ];
+ useLegacyConfig = false;
+ config = {
+ LoadModule = [ "adminlog" ];
+ Motd = "welcome to znc.simatime.com";
+ User.bsima = {
+ Admin = true;
+ Nick = "bsima";
+ AltNick = "bsima1";
+ LoadModule = [ "chansaver" "controlpanel" "log" ];
+ Network = {
+ efnet = {
+ Server = "irc.efnet.info +6697";
+ LoadModule = [ "simple_away" ];
+ };
+ libera = {
+ Server = "irc.libera.chat +6697";
+ LoadModule = [ "simple_away" "nickserv" "sasl" ];
+ Nick = "bsima";
+ Chan = {
+ "#emacs" = { Detached = true; };
+ "#guile" = { };
+ "#guix" = { Detached = true; };
+ "#haskell" = { };
+ "#hledger" = { };
+ "#nixos" = { };
+ "#notmuch" = { Detached = true; };
+ "#org-mode" = { Detached = true; };
+ "#scheme" = { Detached = true; };
+ "#sr.ht" = { Detached = true; };
+ "#xmonad" = { Detached = true; };
+ };
+ };
+ oftc = {
+ Server = "irc.oftc.net +6697";
+ LoadModule = [ "simple_away" "nickserv" ];
+ Nick = "bsima";
+ Chan = { "#home-manager" = { }; };
+ };
+ zeronode = {
+ Server = "irc.zeronode.net +6697";
+ LoadModule = [ "simple_away" "nickserv" ];
+ Nick = "bsima";
+ Chan = { "#NoAgenda" = { }; };
+ };
+ #sorcery = {
+ # Server = "irc.sorcery.net +6697";
+ #};
+ };
+ Pass.password = {
+ Method = "sha256";
+ Hash =
+ "bead16d806e7bf5cbbc31d572b20f01e2b253eb60e2497ce465df56306becd02";
+ Salt = "/GhmBMc+E6b7qd8muFEe";
+ };
+ };
+ };
+ };
+ };
+}