summaryrefslogtreecommitdiff
path: root/Omni/Os/Boot.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-20 13:57:22 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:08:10 -0500
commit87ead51331bc57326882055e1635a84c2d409af7 (patch)
treefb82796cb4dc7247eecb73ead2904f14a96bf17e /Omni/Os/Boot.nix
parente7d6505ff6bfefa927466361570cedde799e94a6 (diff)
Create a bootstrap image for Digital Ocean droplets
I need a way to reliably get a NixOS VM provisioned in the cloud, and the easiest way to do this is to create a qcow2 image, upload it to Digital Ocean, and use that to start a droplet. This is very much a manual process, but that's fine, I shouldn't need to do it very often (for now).
Diffstat (limited to 'Omni/Os/Boot.nix')
-rw-r--r--Omni/Os/Boot.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/Omni/Os/Boot.nix b/Omni/Os/Boot.nix
new file mode 100644
index 0000000..c789d89
--- /dev/null
+++ b/Omni/Os/Boot.nix
@@ -0,0 +1,14 @@
+{ bild }:
+/* This target creates a qcow2 image of a barebones NixOS VM which should be used
+ to bootstrap a deployment target.
+
+ The workflow is like this:
+
+ - bild this, you get a qcow2 image
+ - go to https://cloud.digitalocean.com/images/custom_images
+ - upload the image
+ - start a new droplet with this image
+ - once fully provisioned and accessible via ssh, the new droplet can be a deploy
+ target for any other namespace
+*/
+bild.droplet { imports = [ ./Base.nix ../Users.nix ]; }