summaryrefslogtreecommitdiff
path: root/Omni/Packages.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Omni/Packages.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Omni/Packages.nix')
-rw-r--r--Omni/Packages.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/Omni/Packages.nix b/Omni/Packages.nix
new file mode 100644
index 0000000..d04dfc3
--- /dev/null
+++ b/Omni/Packages.nix
@@ -0,0 +1,22 @@
+{ pkgs, ... }:
+
+# Base set of packages to be expected everywhere.
+
+with pkgs;
+
+{
+ environment.systemPackages = [
+ file
+ fd
+ gitAndTools.gitMinimal
+ htop
+ openssl
+ ranger
+ inetutils
+ traceroute
+ vim
+ vnstat
+ wireguard-tools
+ wget
+ ];
+}