summaryrefslogtreecommitdiff
path: root/Omni/Packages.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-20 13:57:22 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:08:10 -0500
commit87ead51331bc57326882055e1635a84c2d409af7 (patch)
treefb82796cb4dc7247eecb73ead2904f14a96bf17e /Omni/Packages.nix
parente7d6505ff6bfefa927466361570cedde799e94a6 (diff)
Create a bootstrap image for Digital Ocean droplets
I need a way to reliably get a NixOS VM provisioned in the cloud, and the easiest way to do this is to create a qcow2 image, upload it to Digital Ocean, and use that to start a droplet. This is very much a manual process, but that's fine, I shouldn't need to do it very often (for now).
Diffstat (limited to 'Omni/Packages.nix')
-rw-r--r--Omni/Packages.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/Omni/Packages.nix b/Omni/Packages.nix
index d04dfc3..66c1983 100644
--- a/Omni/Packages.nix
+++ b/Omni/Packages.nix
@@ -5,6 +5,17 @@
with pkgs;
{
+ fonts.fonts = with pkgs; [
+ google-fonts
+ mononoki
+ source-code-pro
+ fantasque-sans-mono
+ hack-font
+ fira
+ fira-code
+ fira-code-symbols
+ ];
+
environment.systemPackages = [
file
fd