summaryrefslogtreecommitdiff
path: root/Que/Host.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-12-04 11:16:25 -0500
committerBen Sima <ben@bsima.me>2020-12-05 07:55:13 -0500
commit330e4363d8abb509031d2c8c1a89dcc6f955e2c1 (patch)
tree915c8c50a7125bf6eb9e560f8d00a80592f41c77 /Que/Host.nix
parent32f53350a3a3d701e9a1474e670a8454342adc40 (diff)
Renamespace Devalloc and Que
Move them under the Biz root so that we know they are specific to Biz stuff. Biz is for proprietary stuff that we own. I also had to refactor the bild namespace parsing code because it couldn't handle a namespace with 3 parts. I really need to get that namespace library written and tested.
Diffstat (limited to 'Que/Host.nix')
-rw-r--r--Que/Host.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/Que/Host.nix b/Que/Host.nix
deleted file mode 100644
index e326483..0000000
--- a/Que/Host.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{ options
-, lib
-, config
-, pkgs
-, modulesPath
-}:
-
-let
- cfg = config.services.que-server;
-in
-{
- options.services.que-server = {
- enable = lib.mkEnableOption "Enable the que-server service";
- port = lib.mkOption {
- type = lib.types.int;
- default = 3000;
- description = ''
- The port on which que-server will listen for
- incoming HTTP traffic.
- '';
- };
- package = lib.mkOption {
- type = lib.types.package;
- description = "que-server package to use";
- };
- };
- config = lib.mkIf cfg.enable {
- systemd.services.que-server = {
- path = [ cfg.package ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- ${cfg.package}/bin/que-server
- '';
- description = ''
- Que server
- '';
- serviceConfig = {
- Environment = ["QUE_PORT=${toString cfg.port}"];
- KillSignal = "INT";
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "1";
- };
- };
- };
-}