summaryrefslogtreecommitdiff
path: root/Urbit/Harbor.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Urbit/Harbor.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Urbit/Harbor.nix')
-rw-r--r--Urbit/Harbor.nix47
1 files changed, 19 insertions, 28 deletions
diff --git a/Urbit/Harbor.nix b/Urbit/Harbor.nix
index 50abc53..6098163 100644
--- a/Urbit/Harbor.nix
+++ b/Urbit/Harbor.nix
@@ -1,40 +1,31 @@
-{ options
-, lib
-, config
-, pkgs
-, ...
-}:
+{ options, lib, config, pkgs, ... }:
-/*
+/* Urbit Harbor is a supervisor for Urbit ships on the local machine. It does no
+ orchestration, it just manages systemd services.
-Urbit Harbor is a supervisor for Urbit ships on the local machine. It does no
-orchestration, it just manages systemd services.
+ Setup process:
-Setup process:
+ <running as user "urbit-harbor">
+ dir=/var/urbit/harbor
+ urbit -c $dir/zod -k $dir/zod.key -x # one-time setup
+ <create $dir/zod.service from some template>
+ systemctl --user enable $dir/zod.service # nees fullpath
+ systemctl --user start zod.service
- <running as user "urbit-harbor">
- dir=/var/urbit/harbor
- urbit -c $dir/zod -k $dir/zod.key -x # one-time setup
- <create $dir/zod.service from some template>
- systemctl --user enable $dir/zod.service # nees fullpath
- systemctl --user start zod.service
+ Service Template:
+ [Service]
+ ExecStart=urbit -tq /var/urbit/harbor/zod # maybe want -d?
+ ExecStartPre=mkdir -p /var/urbit/harbor/zod
-Service Template:
+ [Unit]
+ Description=zod
- [Service]
- ExecStart=urbit -tq /var/urbit/harbor/zod # maybe want -d?
- ExecStartPre=mkdir -p /var/urbit/harbor/zod
-
- [Unit]
- Description=zod
-
- [Install]
- WantedBy=multi-user.target
+ [Install]
+ WantedBy=multi-user.target
*/
-let
- cfg = config.services.urbit-harbor;
+let cfg = config.services.urbit-harbor;
in {
options.services.urbitharbor = {
enable = lib.mkEnableOption "Enable urbit-harbor";