summaryrefslogtreecommitdiff
path: root/Urbit/Ship.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Urbit/Ship.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Urbit/Ship.nix')
-rw-r--r--Urbit/Ship.nix11
1 files changed, 3 insertions, 8 deletions
diff --git a/Urbit/Ship.nix b/Urbit/Ship.nix
index ec6a9ec..45f6b72 100644
--- a/Urbit/Ship.nix
+++ b/Urbit/Ship.nix
@@ -1,5 +1,4 @@
-{ bild ? import ../Biz/Bild.nix {}
-}:
+{ bild ? import ../Biz/Bild.nix { } }:
# This represents a single ship running in a container.
@@ -33,12 +32,8 @@ in bild.image {
contents = bild.pkgs.urbit;
config = {
- Cmd = [
- "${urbit-start}"
- ];
+ Cmd = [ "${urbit-start}" ];
WorkingDir = "/";
- Volumes = {
- "/" = { };
- };
+ Volumes = { "/" = { }; };
};
}