summaryrefslogtreecommitdiff
path: root/com/influencedbybooks.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-10-27 12:43:49 -0700
committerBen Sima <ben@bsima.me>2019-11-01 14:22:07 -0700
commitc6662575a085242fd216729ee3429a8b69f91f73 (patch)
tree37a017fe67fd2e2a6e99dd72515e572a92898253 /com/influencedbybooks.nix
parentf82fddd83e8b713e211b6c3a7fcb0eacd88c3689 (diff)
use a standard buildNixOS function
Diffstat (limited to 'com/influencedbybooks.nix')
-rw-r--r--com/influencedbybooks.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/com/influencedbybooks.nix b/com/influencedbybooks.nix
deleted file mode 100644
index f9d0f36..0000000
--- a/com/influencedbybooks.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{ options
-, lib
-, config
-, pkgs
-, modulesPath
-}:
-
-let
- cfg = config.services.ibb;
-in
-{
- options.services.ibb = {
- enable = lib.mkEnableOption "Enable the IBB service";
- port = lib.mkOption {
- type = lib.types.string;
- default = "3000";
- description = ''
- The port on which IBB will listen for
- incoming HTTP traffic.
- '';
- };
- };
- config = lib.mkIf cfg.enable {
- systemd.services.ibb = {
- path = with pkgs; [ ibb bash ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- PORT=${cfg.port} ./bin/ibb
- '';
- description = ''
- Influenced By Books website
- '';
- serviceConfig = {
- WorkingDirectory = pkgs.ibb;
- KillSignal = "INT";
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "10";
- };
- };
- };
-}