summaryrefslogtreecommitdiff
path: root/com/simatime/fathom.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-10-27 09:48:52 -0700
committerBen Sima <ben@bsima.me>2019-10-27 12:14:40 -0700
commitc790672cc244ac4caba1bda3572829a6c6862891 (patch)
tree2706bb8044f7b14840c5f90f215b79b433e81045 /com/simatime/fathom.nix
parent44df4ba39f65c3afd84bee6b03f47d9b061e9038 (diff)
move everything to namespace directories
Diffstat (limited to 'com/simatime/fathom.nix')
-rw-r--r--com/simatime/fathom.nix109
1 files changed, 109 insertions, 0 deletions
diff --git a/com/simatime/fathom.nix b/com/simatime/fathom.nix
new file mode 100644
index 0000000..40e8b0b
--- /dev/null
+++ b/com/simatime/fathom.nix
@@ -0,0 +1,109 @@
+{ options
+, lib
+, config
+, pkgs
+, modulesPath
+, stdenv
+}:
+
+with lib;
+
+let
+ cfg = config.services.fathom
+ pkgs.fathom = stdenv.mkDerivation rec {
+ name = "fathom-v${version}";
+ version = "1.2.1";
+ src = builtins.fetchurl {
+ url = "https://github.com/usefathom/fathom/releases/download/v${version}/fathom_${version}_linux_amd64.tar.gz";
+ sha256 = "0sfpxh2xrvz992k0ynib57zzpcr0ikga60552i14m13wppw836nh";
+ };
+ sourceRoot = ".";
+ dontBuild = true;
+ installPhase = ''
+ mkdir -p $out/bin
+ cp fathom $out/bin
+ cp LICENSE $out
+ cp README.md $out
+ '';
+ };
+in {
+ options.services.fathom = {
+ enable = lib.mkEnableOption "Enable the Fathom Analytics service";
+
+ port = mkOption {
+ type = types.string;
+ default = "3000";
+ description = ''
+ The port on which Fathom will listen for
+ incoming HTTP traffic.
+ '';
+ };
+
+ gzip = mkOption {
+ type = types.bool;
+ default = true;
+ description = "Whether or not to enable gzip compression.";
+ };
+
+ debug = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Whether or not to enable debug mode.";
+ };
+
+ dataDir = mkOption {
+ type = types.path;
+ default = "/var/lib/fathom";
+ description = "Fathom data directory";
+ };
+ };
+
+ config = mkIf cfg.enable {
+ systemd.services.fathom = {
+ wantedBy = [ "multi-user.target" ];
+ after = [ "network.target" ];
+
+ environment = {
+ FATHOM_SERVER_ADDR = cfg.port;
+ FATHOM_GZIP = builtins.toString cfg.gzip;
+ FATHOM_DEBUG = builtins.toString cfg.debug;
+ FATHOM_DATABASE_DRIVER = "sqlite3";
+ FATHOM_DATABASE_NAME = "${cfg.dataDir}/fathom.db";
+ FATHOM_SECRET = "random-secret-string";
+ };
+ preStart = ''
+ echo "[fathom] creating ${cfg.dataDir}"
+ mkdir -p ${cfg.dataDir}
+ chown -R fathom:fathom ${cfg.dataDir}
+ echo "[fathom]" creating ${cfg.dataDir}/.env
+ env | grep "^FATHOM" > ${cfg.dataDir}/.env
+ '';
+ description = ''
+ Fathom Analytics
+ '';
+
+ serviceConfig = {
+ Type = "simple";
+ User = "fathom";
+ Group = "fathom";
+ ExecStart = "${pkgs.fathom}/bin/fathom server";
+ KillSignal = "INT";
+ WorkingDirectory = cfg.dataDir;
+ Restart = "on-failure";
+ RestartSec = "10";
+ PermissionsStartOnly = "true";
+ };
+ };
+
+ environment.systemPackages = [ pkgs.fathom ];
+
+ users = {
+ groups = { fathom = {}; };
+ users.fathom = {
+ description = "Fathom daemon user";
+ home = cfg.dataDir;
+ group = "fathom";
+ };
+ };
+ };
+}