summaryrefslogtreecommitdiff
path: root/com/simatime/git.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-10-27 09:48:52 -0700
committerBen Sima <ben@bsima.me>2019-10-27 12:14:40 -0700
commitc790672cc244ac4caba1bda3572829a6c6862891 (patch)
tree2706bb8044f7b14840c5f90f215b79b433e81045 /com/simatime/git.nix
parent44df4ba39f65c3afd84bee6b03f47d9b061e9038 (diff)
move everything to namespace directories
Diffstat (limited to 'com/simatime/git.nix')
-rw-r--r--com/simatime/git.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/com/simatime/git.nix b/com/simatime/git.nix
new file mode 100644
index 0000000..51e46b6
--- /dev/null
+++ b/com/simatime/git.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }:
+
+{
+ services = {
+ gitolite = {
+ enable = true;
+ enableGitAnnex = true;
+ # TODO: change this to /var/lib/gitolite?
+ dataDir = "/srv/git";
+ user = "git";
+ group = "git";
+ extraGitoliteRc = ''
+ $RC{SITE_INFO} = 'a computer is a bicycle for the mind.';
+ '';
+ adminPubkey = builtins.readFile ./keys/ben.pub;
+ };
+ };
+}