summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-03-31 17:12:09 -0700
committerBen Sima <ben@bsima.me>2020-03-31 17:12:09 -0700
commit9493e2dbf9671d55fea2a96aa057589670e9673a (patch)
tree6702a9bc37826d8fd1f522a7ab16a7a2b696447d /default.nix
parent721cca4b1372e222c6841ddc57bb952271d72dc7 (diff)
Massively improve the que-website
curl was throwing an exception if the file got too long, because I was passing the entire file contents in the arguments to curl. I tried using a tmp file but that didn't work for some reason. So I switched to req and that seems to work well. I also made it faster by serving all pages concurrently, and I spruced up the CSS a ton.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 13ded48..5622c74 100644
--- a/default.nix
+++ b/default.nix
@@ -176,6 +176,11 @@ in rec {
Run.Que.Website = buildGhc {
name = "Run.Que.Website";
nick = "que-website";
- deps = [ "process" ];
+ deps = [
+ "async"
+ "process"
+ "protolude"
+ "req"
+ ];
};
}