summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-11-01 14:24:24 -0700
committerBen Sima <ben@bsima.me>2019-11-01 14:25:49 -0700
commit9756eb0806aef63137ed53c7f78eee13aa3db9d7 (patch)
tree0c3bf0becc08e37386109ff8c518fa442df6266b /default.nix
parent0a6fd40946f72e9995ca04b05d7556bf20585d4f (diff)
add buildHaskellApp nix function
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix36
1 files changed, 35 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index e3d3ca1..aedf4a0 100644
--- a/default.nix
+++ b/default.nix
@@ -8,7 +8,7 @@ let
system = full.system;
vm = full.vm;
};
-
+ buildHaskellApp = import ./com/simatime/buildHaskellApp.nix nixpkgs;
in {
com.simatime = import ./com/simatime.nix { inherit buildNixOS; };
com.influencedbybooks = buildNixOS {
@@ -28,4 +28,38 @@ in {
security.sudo.wheelNeedsPassword = true;
boot.cleanTmpDir = true;
};
+ } // {
+ ibb = buildHaskellApp {
+ name = "Com.Influencedbybooks";
+ apex = "Com.Influencedbybooks.Apex";
+ aero = "Com.Influencedbybooks.Aero";
+ deps = {
+ both = [
+ "clay"
+ "miso"
+ "protolude"
+ "servant"
+ "text"
+ ];
+ apex = [
+ "MonadRandom"
+ "acid-state"
+ "blaze-html"
+ "blaze-markup"
+ "bytestring"
+ "ixset"
+ "random"
+ "safecopy"
+ "scotty"
+ "servant-server"
+ "text"
+ ];
+ aero = [
+ "aeson"
+ "containers"
+ "ghcjs-base"
+ ];
+ };
+ };
+ };
}