summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-03-31 11:39:49 -0700
committerBen Sima <ben@bsima.me>2020-03-31 12:02:10 -0700
commit9f3804d5e4f28ea61a8abc856210422ad794b55e (patch)
treea2f12f2d227cec6bab827feef4ec2e49a5cbf5d0 /default.nix
parent0b0972d31ab263c12d2cba621794bc6e7c3840bf (diff)
Add Run.Que.Website server
This is a simple website server that uses que.run itself to host the que webpages. I had to rename Run.Que to Run.Que.Server because nix was complaining about Run.Que being both a derivation and an attrset with Run.Que.Website in it.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/default.nix b/default.nix
index 54db612..13ded48 100644
--- a/default.nix
+++ b/default.nix
@@ -49,7 +49,7 @@ in rec {
};
};
Com.Simatime.Serval = buildOS {
- deps = { que-server = Run.Que; };
+ deps = { que-server = Run.Que.Server; };
configuration = {
imports = [
./Com/Simatime/packages.nix
@@ -161,19 +161,21 @@ in rec {
];
};
};
- Run.Que = buildGhc {
- name = "Run.Que";
+ Run.Que.Server = buildGhc {
+ name = "Run.Que.Server";
nick = "que-server";
deps = [
- "aeson"
"async"
"protolude"
"scotty"
- "servant"
- "servant-server"
"stm"
"unagi-chan"
"unordered-containers"
];
};
+ Run.Que.Website = buildGhc {
+ name = "Run.Que.Website";
+ nick = "que-website";
+ deps = [ "process" ];
+ };
}