summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-03 21:12:54 -0700
committerBen Sima <ben@bsima.me>2020-04-03 21:12:54 -0700
commitd5025c552911b29bb8f2250c5b4aa1f9917a68e4 (patch)
tree6f5f73f8ab6f1386a2c86981f98c2253c44e745d /default.nix
parent49908f6e7662c6ad0479e53b6176e5e06b78734b (diff)
Add wemux to the dev machine
I also had to refactor the overlays stuff a bit, but it is much nicer now.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 9ac2286..e213bc4 100644
--- a/default.nix
+++ b/default.nix
@@ -1,11 +1,11 @@
let
nixpkgs-tar = builtins.fetchTarball (import ./nixpkgs.nix);
- overlay = import ./overlays.nix;
- nixpkgs = import "${nixpkgs-tar}" { overlays = [ overlay ]; };
+ overlay = import ./overlay.nix;
+ bizpkgs = import "${nixpkgs-tar}" { overlays = [ overlay ]; };
nixos = import "${nixpkgs-tar}/nixos";
# TODO(bsima): buildNixOS should be split into multiple functions that each
# return one thing, instead of a single function that returns multiple things
- biz = import ./biz.nix { inherit nixpkgs; };
+ biz = import ./biz.nix { nixpkgs = bizpkgs; };
buildOS = import ./Com/Simatime/buildOS.nix nixos;
nixos-mailserver = let ver = "v2.3.0"; in builtins.fetchTarball {
url = "https://gitlab.com/simple-nixos-mailserver/nixos-mailserver/-/archive/${ver}/nixos-mailserver-${ver}.tar.gz";
@@ -40,6 +40,9 @@ in rec {
Com.Simatime.Dev = buildOS {
enableVpn = true;
ipAddress = "73.222.221.63";
+ deps = {
+ wemux = bizpkgs.wemux;
+ };
configuration = {
imports = [
./Com/Simatime/packages.nix
@@ -54,7 +57,9 @@ in rec {
# The production server for apps
#
Com.Simatime.Prod = buildOS {
- deps = { que-server = Run.Que.Server; };
+ deps = {
+ que-server = Run.Que.Server;
+ };
configuration = {
imports = [
./Com/Simatime/packages.nix
@@ -79,4 +84,6 @@ in rec {
Run.Que.Website = biz.buildGhc ./Run/Que/Website.hs;
# Development environment
repl = biz.globalGhc;
+ # Fall through to any of our overlay packages
+ inherit bizpkgs;
}