summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-05 15:53:37 -0700
committerBen Sima <ben@bsima.me>2020-04-05 15:53:37 -0700
commite5dbfd32b52e35aecf961b8b80a5f70e76c3cb83 (patch)
treed450a29f3679e815a0c47b7f37d5969f2f80247b /default.nix
parentf0e5894c625a726b5364365298f144e862b23676 (diff)
Deploy que.run without nginx
I still have to reimplement the SSL stuff but in the Haskell code. That seems kinda hard or at least requires research that I don't wanna do right now.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/default.nix b/default.nix
index ad1f750..ea20799 100644
--- a/default.nix
+++ b/default.nix
@@ -52,9 +52,9 @@ in rec {
networking.domain = "dev.simatime.com";
};
};
- # The production server for apps
+ # The production server for que.run
#
- Com.Simatime.Prod = buildOS {
+ Run.Que.Prod = buildOS {
deps = {
que-server = Run.Que.Server;
};
@@ -62,14 +62,11 @@ in rec {
imports = [
./Com/Simatime/packages.nix
./Com/Simatime/users.nix
- ./Com/Simatime/Prod/hardware.nix
- ./Com/Simatime/Prod/networking.nix
- ./Com/Simatime/Prod/configuration.nix
- ./Run/Que/service.nix
+ ./Run/Que/Server.nix
+ ./Run/Que/Prod.nix
];
- networking.hostName = "prod";
- networking.domain = "prod.simatime.com";
- boot.enableContainers = true;
+ networking.hostName = "prod.que.run";
+ networking.domain = "que.run";
};
};
# Haskell targets