summaryrefslogtreecommitdiff
path: root/depo/hikuj-zupip/hardware.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-06-07 12:16:27 -0700
committerBen Sima <ben@bsima.me>2019-06-07 12:18:48 -0700
commit3971bd1e35dc9ec72b3aa50f29b2f82d1e06cf72 (patch)
tree0edee704157bb4ddd95e5277a783fdfea2bff68e /depo/hikuj-zupip/hardware.nix
parent8bf3f4e98d71d7c4e2dc3651fe7094f33f9f409a (diff)
rename lithium and activate gitlab-runner
Diffstat (limited to 'depo/hikuj-zupip/hardware.nix')
-rw-r--r--depo/hikuj-zupip/hardware.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/depo/hikuj-zupip/hardware.nix b/depo/hikuj-zupip/hardware.nix
new file mode 100644
index 0000000..fc0e7a0
--- /dev/null
+++ b/depo/hikuj-zupip/hardware.nix
@@ -0,0 +1,34 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "sd_mod" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/0d8b0e52-10de-4af2-bcd9-b36278352e77";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/9B89-85C7";
+ fsType = "vfat";
+ };
+
+ fileSystems."/mnt/lake" =
+ { device = "/dev/disk/by-uuid/037df3ae-4609-402c-ab1d-4593190d0ee7";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 4;
+ powerManagement.cpuFreqGovernor = "powersave";
+}