summaryrefslogtreecommitdiff
path: root/depo/nutin-madaj/configuration.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-05-12 14:20:23 -0700
committerBen Sima <ben@bsima.me>2019-05-12 14:20:23 -0700
commit2eebdc423c1cdac026b88374883796ebea90514a (patch)
tree6a56148b5f124149ae56ab3ea977ae297b533702 /depo/nutin-madaj/configuration.nix
parent2f017e1b0926d3141067f0a5bc810be32c335e61 (diff)
wip: upgrade nixos, mailserver, and enable znc
Diffstat (limited to 'depo/nutin-madaj/configuration.nix')
-rw-r--r--depo/nutin-madaj/configuration.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/depo/nutin-madaj/configuration.nix b/depo/nutin-madaj/configuration.nix
index 6ca0de1..919ae1b 100644
--- a/depo/nutin-madaj/configuration.nix
+++ b/depo/nutin-madaj/configuration.nix
@@ -69,6 +69,42 @@ in
};
};
};
+
+ znc = {
+ enable = true;
+ mutable = true;
+ useLegacyConfig = false;
+ openFirewall = true;
+ config = {
+ LoadModule = [ "adminlog" "fail2ban" ];
+ User.bsima = {
+ Admin = true;
+ Nick = "bsima";
+ AltNick = "bsima1";
+ LoadModule = [ "chansaver" "controlpanel" ];
+ Network.freenode = { Server = "chat.freenode.net +6697";
+ LoadModule = [ "simple_away" "nickserv" ];
+ Chan = {
+ "#ai" = {};
+ "#bsima" = {};
+ "#emacs" = {};
+ "#haskell" = {};
+ "#haskell-miso" = {};
+ "#home-manager" = {};
+ "#nixos" = {};
+ "#servant" = {};
+ "#sr.ht" = {};
+ "#xmonad" = {};
+ };
+ };
+ Pass.password = {
+ Method = "sha256";
+ Hash = "4a6703074c713a26d56a906fc9ea82bb591177f10a25a650719266bf588d9525";
+ Salt = "QByO-A:4Rbib;dl_3wEH";
+ };
+ };
+ };
+ };
};
mailserver = {
@@ -108,6 +144,16 @@ in
};
};
+ virtualisation = {
+ libvirtd.enable = true;
+ docker.enable = true;
+ virtualbox.guest.enable = true;
+ virtualbox.host.enable = true;
+ virtualbox.host.headless = false;
+ virtualbox.host.addNetworkInterface = true;
+
+ };
+
boot.cleanTmpDir = true;
networking.hostName = "simatime";
networking.firewall.allowPing = true;