summaryrefslogtreecommitdiff
path: root/depo/nutin-madaj/networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-02-23 19:46:09 -0800
committerBen Sima <ben@bsima.me>2019-02-23 19:54:41 -0800
commitf75eaf7fff963b88e412d315d0fdef8151943c20 (patch)
tree4e10e624ab6b93b640f2a93f648207a41cc90a25 /depo/nutin-madaj/networking.nix
parent81313e15c70bf1c2fe2cd4720f19ae7a2e952fc7 (diff)
Reorganize directory
Diffstat (limited to 'depo/nutin-madaj/networking.nix')
-rw-r--r--depo/nutin-madaj/networking.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/depo/nutin-madaj/networking.nix b/depo/nutin-madaj/networking.nix
new file mode 100644
index 0000000..6c55005
--- /dev/null
+++ b/depo/nutin-madaj/networking.nix
@@ -0,0 +1,30 @@
+{ lib, ... }: {
+ # This file was populated at runtime with the networking
+ # details gathered from the active system.
+ networking = {
+ nameservers = [
+ "67.207.67.2"
+ "67.207.67.3"
+ ];
+ defaultGateway = "159.89.128.1";
+ defaultGateway6 = "";
+ dhcpcd.enable = false;
+ usePredictableInterfaceNames = lib.mkForce true;
+ interfaces = {
+ eth0 = {
+ ipv4.addresses = [
+ { address="159.89.128.69"; prefixLength=20; }
+{ address="10.46.0.6"; prefixLength=16; }
+ ];
+ ipv6.addresses = [
+ { address="fe80::e899:c0ff:fe9c:e194"; prefixLength=64; }
+ ];
+ };
+
+ };
+ };
+ services.udev.extraRules = ''
+ ATTR{address}=="ea:99:c0:9c:e1:94", NAME="eth0"
+
+ '';
+}