summaryrefslogtreecommitdiff
path: root/ibb/module.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-02-16 20:51:58 -0800
committerBen Sima <ben@bsima.me>2019-02-16 20:51:58 -0800
commitcf5b024e189cb4ed85f80b521cf9e0e5dc5b5070 (patch)
treef579a2ff069862856e6a1667426769c165aaa079 /ibb/module.nix
parent225f2c575d18f080daa82d634af7f1fde4f03809 (diff)
Make port configurable
Diffstat (limited to 'ibb/module.nix')
-rw-r--r--ibb/module.nix47
1 files changed, 29 insertions, 18 deletions
diff --git a/ibb/module.nix b/ibb/module.nix
index b4f7609..e2d4dd0 100644
--- a/ibb/module.nix
+++ b/ibb/module.nix
@@ -7,24 +7,35 @@
let
cfg = config.services.ibb;
-in {
- options.services.ibb.enable = lib.mkEnableOption "Enable the IBB service";
- config = lib.mkIf cfg.enable {
- systemd.services.ibb = {
- path = with pkgs; [ ibb bash ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- ./bin/ibb
- '';
- description = ''
- Influenced By Books website
- '';
- serviceConfig = {
- WorkingDirectory=pkgs.ibb;
- KillSignal="INT";
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "10";
+in
+{
+ options.services.ibb = {
+ enable = lib.mkEnableOption "Enable the IBB service";
+ port = lib.mkOption {
+ type = lib.types.string;
+ default = "3000";
+ description = ''
+ The port on which IBB will listen for
+ incoming HTTP traffic.
+ '';
+ };
+ };
+ config = lib.mkIf cfg.enable {
+ systemd.services.ibb = {
+ path = with pkgs; [ ibb bash ];
+ wantedBy = [ "multi-user.target" ];
+ script = ''
+ PORT=${cfg.port} ./bin/ibb
+ '';
+ description = ''
+ Influenced By Books website
+ '';
+ serviceConfig = {
+ WorkingDirectory=pkgs.ibb;
+ KillSignal="INT";
+ Type = "simple";
+ Restart = "on-abort";
+ RestartSec = "10";
};
};
};