summaryrefslogtreecommitdiff
path: root/lore/bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-10-09 22:10:48 -0700
committerBen Sima <ben@bsima.me>2019-10-09 22:10:48 -0700
commitaa0cd5e980faf1cb0b33105f86f32a8aa64f53f4 (patch)
tree9e57fbfcb1c1dbbec51a72a1a1588d95411140ab /lore/bild.nix
parent89e8e4bbc0fe70dd7f8742e3ccfec492f281fb19 (diff)
[bild] add clay dependency
Diffstat (limited to 'lore/bild.nix')
-rw-r--r--lore/bild.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/lore/bild.nix b/lore/bild.nix
index 9f439f8..589fda9 100644
--- a/lore/bild.nix
+++ b/lore/bild.nix
@@ -12,13 +12,19 @@
depsToPackageSet = packageSet: deps:
map (s: builtins.getAttr s packageSet) deps;
- ghc = pkgs.haskell.packages.ghc844.ghcWithPackages (hp:
+ ghc844_ = pkgs.haskell.packages.ghc844.override (oldAttrs: {
+ overrides = with pkgs.haskell.lib; self: super: {
+ clay = dontCheck super.clay;
+ };
+ });
+
+ ghc = ghc844_.ghcWithPackages (hp: depsToPackageSet hp
# we need hinotify for chip/make
- depsToPackageSet hp
- ([ "hinotify" ] ++ pack.deps.both ++ pack.deps.apex));
+ ([ "hinotify" ] ++ pack.deps.both ++ pack.deps.apex));
ghcjs_ = pkgs.haskell.packages.ghcjs.override (oldAttrs: {
overrides = with pkgs.haskell.lib; self: super: {
+ clay = dontCheck super.clay;
http-types = dontCheck super.http-types;
tasty-quickcheck = dontCheck super.tasty-quickcheck;
scientific = dontCheck super.scientific; # takes forever