summaryrefslogtreecommitdiff
path: root/networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-01-30 17:20:43 -0800
committerBen Sima <ben@bsima.me>2019-01-30 17:20:43 -0800
commit67ddf074edec7631067c5f634c3e56e0848cd11f (patch)
treec1d309daade3b6bbc507b845dd1c4c23b1ccdfca /networking.nix
parent6750622c47a90060159544c8c928ef3440a43ec9 (diff)
Build production machine locally
Diffstat (limited to 'networking.nix')
-rw-r--r--networking.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/networking.nix b/networking.nix
new file mode 100644
index 0000000..6c55005
--- /dev/null
+++ b/networking.nix
@@ -0,0 +1,30 @@
+{ lib, ... }: {
+ # This file was populated at runtime with the networking
+ # details gathered from the active system.
+ networking = {
+ nameservers = [
+ "67.207.67.2"
+ "67.207.67.3"
+ ];
+ defaultGateway = "159.89.128.1";
+ defaultGateway6 = "";
+ dhcpcd.enable = false;
+ usePredictableInterfaceNames = lib.mkForce true;
+ interfaces = {
+ eth0 = {
+ ipv4.addresses = [
+ { address="159.89.128.69"; prefixLength=20; }
+{ address="10.46.0.6"; prefixLength=16; }
+ ];
+ ipv6.addresses = [
+ { address="fe80::e899:c0ff:fe9c:e194"; prefixLength=64; }
+ ];
+ };
+
+ };
+ };
+ services.udev.extraRules = ''
+ ATTR{address}=="ea:99:c0:9c:e1:94", NAME="eth0"
+
+ '';
+}