summaryrefslogtreecommitdiff
path: root/nix/haskell-overlay.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-07-25 22:24:44 -0700
committerBen Sima <ben@bsima.me>2020-07-25 23:25:05 -0700
commit01bda0f0aa87c34a30253ffd1d5b60b33644f6d8 (patch)
tree8d2ac795680b8379c44bfe7f4817753482b3b961 /nix/haskell-overlay.nix
parent2f32da5812583c6675bdc9ff88a3a3d5cefbb82f (diff)
bild: support incremental compilation
Closes https://github.com/bsima/biz/issues/9
Diffstat (limited to 'nix/haskell-overlay.nix')
-rw-r--r--nix/haskell-overlay.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nix/haskell-overlay.nix b/nix/haskell-overlay.nix
index 3c7ec76..a6aad12 100644
--- a/nix/haskell-overlay.nix
+++ b/nix/haskell-overlay.nix
@@ -23,6 +23,7 @@ in
ghcjs = pkgs.haskell.packages.ghcjs.override (old: {
overrides = with pkgs.haskell.lib; self: super:
pkgs.overridePinnedDeps (simpleCabalBuilder self) // {
+ Glob = dontCheck super.Glob;
QuickCheck = dontCheck super.QuickCheck;
base-compat-batteries = dontCheck super.http-types;
clay = dontCheck super.clay;
@@ -32,6 +33,7 @@ in
network-uri= dontCheck super.network-uri;
scientific = dontCheck super.scientific; # takes forever
servant = dontCheck super.servant;
+ servant-auth = buildCabal self "servant-auth" "servant-auth";
tasty-quickcheck = dontCheck super.tasty-quickcheck;
time-compat = dontCheck super.time-compat;
};