summaryrefslogtreecommitdiff
path: root/overlay.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-10 14:46:45 -0700
committerBen Sima <ben@bsima.me>2020-04-10 14:46:45 -0700
commit72af3505b2882b090c833532eff9204a46004dcd (patch)
tree03e480f21eb9a8af026751bb6776a159598b036c /overlay.nix
parentd0b74c55a07ce9e623578bf35d37a597e1a3c179 (diff)
Get the ghcjs build working
Diffstat (limited to 'overlay.nix')
-rw-r--r--overlay.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/overlay.nix b/overlay.nix
index 77bf9b4..dcadf34 100644
--- a/overlay.nix
+++ b/overlay.nix
@@ -7,12 +7,25 @@ let
rev = "cc7729b1b42a79e261091ff7835f7fc2a7ae3cee";
sha256 = "1vd67976lvi5l4qq18zy6j44apynkl44ps04p8vwfx4gzr895dyp";
};
+ jsaddleSrc = super.pkgs.fetchFromGitHub {
+ owner = "ghcjs";
+ repo = "jsaddle";
+ rev = "1e39844";
+ sha256 = "1qrjrjagmrrlcalys33636w5cb67db52i183masb7xd93wir8963";
+ };
+ misoSrc = super.pkgs.fetchFromGitHub {
+ owner = "dmjio";
+ repo = "miso";
+ rev = "1.5";
+ sha256 = "00al7gw760vzzlqpf035k4n4li0rdymcjpxn184z9nc4m92cjv9z";
+ };
in {
haskell = super.haskell // {
packages = super.haskell.packages // {
ghc865 = super.haskell.packages.ghc865.override (old: {
overrides = with super.pkgs.haskell.lib; self: super: {
clay = self.callCabal2nix "clay" claySrc {};
+ miso = self.callCabal2nix "miso" misoSrc {};
wai-middleware-metrics = dontCheck super.wai-middleware-metrics;
};
});
@@ -22,7 +35,9 @@ in {
base-compat-batteries = dontCheck super.http-types;
clay = dontCheck (self.callCabal2nix "clay" claySrc {});
comonad = dontCheck super.comonad;
+ jsaddle-warp = dontCheck (self.callCabal2nix "jsaddle-warp" "${jsaddleSrc}/jsaddle-warp" {});
http-types = dontCheck super.http-types;
+ miso = self.callCabal2nix "miso" misoSrc {};
network-uri= dontCheck super.network-uri;
scientific = dontCheck super.scientific; # takes forever
servant = dontCheck super.servant;