summaryrefslogtreecommitdiff
path: root/overlays.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-03 21:12:54 -0700
committerBen Sima <ben@bsima.me>2020-04-03 21:12:54 -0700
commitd5025c552911b29bb8f2250c5b4aa1f9917a68e4 (patch)
tree6f5f73f8ab6f1386a2c86981f98c2253c44e745d /overlays.nix
parent49908f6e7662c6ad0479e53b6176e5e06b78734b (diff)
Add wemux to the dev machine
I also had to refactor the overlays stuff a bit, but it is much nicer now.
Diffstat (limited to 'overlays.nix')
-rw-r--r--overlays.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/overlays.nix b/overlays.nix
deleted file mode 100644
index 5da2957..0000000
--- a/overlays.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-self: super:
-
-let
- claySrc = super.pkgs.fetchFromGitHub {
- owner = "sebastiaanvisser";
- repo = "clay";
- rev = "cc7729b1b42a79e261091ff7835f7fc2a7ae3cee";
- sha256 = "1vd67976lvi5l4qq18zy6j44apynkl44ps04p8vwfx4gzr895dyp";
- };
-in {
- haskell = super.haskell // {
- packages = super.haskell.packages // {
- ghc865 = super.haskell.packages.ghc865.override (old: {
- overrides = with super.pkgs.haskell.lib; self: super: {
- clay = self.callCabal2nix "clay" claySrc {};
- wai-middleware-metrics = dontCheck super.wai-middleware-metrics;
- };
- });
- ghcjs = super.haskell.packages.ghcjs.override (old: {
- overrides = with super.haskell.lib; self: super: {
- QuickCheck = dontCheck super.QuickCheck;
- base-compat-batteries = dontCheck super.http-types;
- clay = dontCheck (self.callCabal2nix "clay" claySrc {});
- comonad = dontCheck super.comonad;
- http-types = dontCheck super.http-types;
- network-uri= dontCheck super.network-uri;
- scientific = dontCheck super.scientific; # takes forever
- servant = dontCheck super.servant;
- tasty-quickcheck = dontCheck super.tasty-quickcheck;
- time-compat = dontCheck super.time-compat;
- };
- });
- };
- };
-}