summaryrefslogtreecommitdiff
path: root/overlays.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-03 15:37:10 -0700
committerBen Sima <ben@bsima.me>2020-04-03 17:55:39 -0700
commite82440741295543769fa79ae05519d58fcb81b08 (patch)
tree7c63e371030947c2a1b0cb21a6687686794a2ccd /overlays.nix
parent4dc2cd1369a9bea6cf0d393059b7ae3a07039f52 (diff)
Factor haskell packages into overlays
Diffstat (limited to 'overlays.nix')
-rw-r--r--overlays.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/overlays.nix b/overlays.nix
new file mode 100644
index 0000000..5da2957
--- /dev/null
+++ b/overlays.nix
@@ -0,0 +1,35 @@
+self: super:
+
+let
+ claySrc = super.pkgs.fetchFromGitHub {
+ owner = "sebastiaanvisser";
+ repo = "clay";
+ rev = "cc7729b1b42a79e261091ff7835f7fc2a7ae3cee";
+ sha256 = "1vd67976lvi5l4qq18zy6j44apynkl44ps04p8vwfx4gzr895dyp";
+ };
+in {
+ haskell = super.haskell // {
+ packages = super.haskell.packages // {
+ ghc865 = super.haskell.packages.ghc865.override (old: {
+ overrides = with super.pkgs.haskell.lib; self: super: {
+ clay = self.callCabal2nix "clay" claySrc {};
+ wai-middleware-metrics = dontCheck super.wai-middleware-metrics;
+ };
+ });
+ ghcjs = super.haskell.packages.ghcjs.override (old: {
+ overrides = with super.haskell.lib; self: super: {
+ QuickCheck = dontCheck super.QuickCheck;
+ base-compat-batteries = dontCheck super.http-types;
+ clay = dontCheck (self.callCabal2nix "clay" claySrc {});
+ comonad = dontCheck super.comonad;
+ http-types = dontCheck super.http-types;
+ network-uri= dontCheck super.network-uri;
+ scientific = dontCheck super.scientific; # takes forever
+ servant = dontCheck super.servant;
+ tasty-quickcheck = dontCheck super.tasty-quickcheck;
+ time-compat = dontCheck super.time-compat;
+ };
+ });
+ };
+ };
+}