summaryrefslogtreecommitdiff
path: root/pack/fathom.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-02-22 15:22:49 -0800
committerBen Sima <ben@bsima.me>2019-02-23 13:25:47 -0800
commit9b2b49e9063d805e68acbef40989075f1b1a6576 (patch)
treec2c5464bb2b6b3bf2c9109d6a2218d9a6d62b222 /pack/fathom.nix
parent3b90927e818729f2983ae7ebe5ab65c0b96bcd2a (diff)
Package and deploy fathom
Diffstat (limited to 'pack/fathom.nix')
-rw-r--r--pack/fathom.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pack/fathom.nix b/pack/fathom.nix
new file mode 100644
index 0000000..a845eb6
--- /dev/null
+++ b/pack/fathom.nix
@@ -0,0 +1,18 @@
+{ nixpkgs }:
+with nixpkgs;
+stdenv.mkDerivation rec {
+ name = "fathom-v${version}";
+ version = "1.2.1";
+ src = builtins.fetchurl {
+ url = "https://github.com/usefathom/fathom/releases/download/v${version}/fathom_${version}_linux_amd64.tar.gz";
+ sha256 = "0sfpxh2xrvz992k0ynib57zzpcr0ikga60552i14m13wppw836nh";
+ };
+ sourceRoot = ".";
+ dontBuild = true;
+ installPhase = ''
+ mkdir -p $out/bin
+ cp fathom $out/bin
+ cp LICENSE $out
+ cp README.md $out
+ '';
+}