summaryrefslogtreecommitdiff
path: root/pack/ibb.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-03-26 12:49:15 -0700
committerBen Sima <ben@bsima.me>2019-03-26 12:52:53 -0700
commit1c51ae337b5a88f17e85ec13be78f6c05802dfc8 (patch)
treee1122d61e3a308843ee3ad0aa373a804e967e18b /pack/ibb.nix
parentf50cecf2cb77cc073cb86a6016468a09d1c49fb0 (diff)
Add a custom make script
Diffstat (limited to 'pack/ibb.nix')
-rw-r--r--pack/ibb.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/pack/ibb.nix b/pack/ibb.nix
index feb99f9..6bf84d8 100644
--- a/pack/ibb.nix
+++ b/pack/ibb.nix
@@ -5,12 +5,14 @@ let
blaze-html
blaze-markup
bytestring
+ hinotify
MonadRandom
random
scotty
shakespeare
text
]);
+ make = ../chip/make;
entrypoint = "Ibb";
in
stdenv.mkDerivation rec {
@@ -21,11 +23,7 @@ stdenv.mkDerivation rec {
ghc
];
strictDeps = true;
- buildPhase = ''
- ${ghc}/bin/ghc -iapex -ilore \
- -main-is ${entrypoint} --make apex/${entrypoint}.hs \
- -o bild/${name}
- '';
+ buildPhase = "${ghc}/bin/runhaskell ${make} ibb";
installPhase = ''
mkdir -p $out/bin
cp bild/${name} $out/bin/${name}