summaryrefslogtreecommitdiff
path: root/pack/ibb.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-03-26 16:45:18 -0700
committerBen Sima <ben@bsima.me>2019-03-26 16:45:18 -0700
commit25e9f0415127434f9e2d7d31d2918671b781132b (patch)
tree604c407829e4601a7f5da41838a1231a06071740 /pack/ibb.nix
parent5d5a5ed8d6d63046ce7452c7a20c6218699b6dfd (diff)
Add sample aero ibb app
Diffstat (limited to 'pack/ibb.nix')
-rw-r--r--pack/ibb.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/pack/ibb.nix b/pack/ibb.nix
index 6bf84d8..d91d119 100644
--- a/pack/ibb.nix
+++ b/pack/ibb.nix
@@ -6,12 +6,30 @@ let
blaze-markup
bytestring
hinotify
+ miso
MonadRandom
random
scotty
shakespeare
text
]);
+ ghcjs_ = pkgs.haskell.packages.ghcjs.override (oldAttrs: {
+ overrides = with pkgs.haskell.lib; self: super: {
+ http-types = dontCheck super.http-types;
+ tasty-quickcheck = dontCheck super.tasty-quickcheck;
+ scientific = dontCheck super.scientific; # takes forever
+ servant = dontCheck super.servant;
+ };
+ });
+ ghcjs = ghcjs_.ghcWithPackages (hp: with hp; [
+ aeson
+ containers
+ ghcjs-base
+ miso
+ protolude
+ servant
+ text
+ ]);
make = ../chip/make;
entrypoint = "Ibb";
in
@@ -20,7 +38,7 @@ stdenv.mkDerivation rec {
version = "0";
src = ../.;
nativeBuildInputs = [
- ghc
+ ghc ghcjs
];
strictDeps = true;
buildPhase = "${ghc}/bin/runhaskell ${make} ibb";