summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-21 10:40:06 -0400
committerBen Sima <ben@bsima.me>2024-12-21 09:40:06 -0500
commit79390d4eea20ca15fd8e088345528f31ed5fad1e (patch)
treef08b71ffddead23484fd6df9e1aff54d20f12768 /pyproject.toml
parent18956baad9cde85bc55bd0113092e51786d9e1ee (diff)
Upgrade to nixos-24.05
I think this is the only "supported" nixos version now. But in any case scipy seemed to be broken on the older version, and I couldn't build my code that uses llm. Also, this allows me to get rid of the bild.os-unstable thing for Beryllium, which was just a sitting timebomb of breaking stuff. There are a lot of changes here because ruff updated to the very latest, and it changed some minor lint things. Also with the new nixos I get a proper cgit module, and some other breaking changes needed fixing.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 025e630..b15c40c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -25,7 +25,9 @@ ignore = [
"CPY001", # missing-copyright-notice
"D203", # no-blank-line-before-class
"D212", # multi-line-summary-first-line
+ "DOC201", # docstring-missing-returns
"E203", # whitespace-before-punctuation, doesn't work with ruff format
+ "EXE001", # shebang-not-executable, remove this when run.sh is working
"INP001", # implicit-namespace-package
"N999", # invalid-module-name
"PLR0402", # manual-from-import, prefer imports like Haskell
@@ -42,3 +44,5 @@ ignore = [
no-sections = true
force-single-line = true
+[tool.ruff.lint.pydocstyle]
+convention = "pep257"