summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-19 16:50:36 -0700
committerBen Sima <ben@bsima.me>2020-04-19 17:51:39 -0700
commit35f0ade5ea77d17544d253f970ef94dd1c7cd9f0 (patch)
tree588c20152bc338f8ded6cba434817b2f8fdd5d1c /shell.nix
parent42d1fab5fd7af5682bd693d4784d9da1a2d4bfef (diff)
Switch to niv for managing third party sources
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/shell.nix b/shell.nix
index 8fe59f8..c0d1e6a 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,10 +3,7 @@
}:
let
- nixpkgs-tar = builtins.fetchTarball (import ./nixpkgs.nix);
- nixpkgs = import "${nixpkgs-tar}" { overlays = [ (import ./overlay.nix) ]; };
- nixos = import "${nixpkgs-tar}/nixos";
- biz = import ./biz.nix { inherit nixpkgs; };
+ nixpkgs = import ./nix/nixpkgs.nix;
in nixpkgs.mkShell ({
name = "bizdev";
buildInputs = [
@@ -19,10 +16,6 @@ in nixpkgs.mkShell ({
nixpkgs.wemux
];
shellHook = ''
- export HERO_PORT=3000
- # TODO: figure out another way to do this
- #export HERO_CLIENT=$PWD/_bild/Com.MusicMeetsComics.Client/static
-
echo "biz" | ${nixpkgs.figlet}/bin/figlet | ${nixpkgs.lolcat}/bin/lolcat
'';
})