summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-07-14 20:29:53 -0700
committerBen Sima <ben@bsima.me>2020-07-14 20:29:53 -0700
commit584239a1a0c97f9d57f2de76c04708127178bceb (patch)
tree9114e816425ad03c521d1b4d37eea986cd5ecbd0 /shell.nix
parentca28f4a86b839d702bdaa70925884aa2bd5cf9ed (diff)
dev: move some commands to shell
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix23
1 files changed, 1 insertions, 22 deletions
diff --git a/shell.nix b/shell.nix
index a83b9af..7e64e11 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,22 +1 @@
-{
- isDevelopmentShell ? true
-}:
-
-let
- nixpkgs = import ./nix/default.nix;
- basepkgs = import ./Biz/packages.nix { inherit (nixpkgs) pkgs; };
- devpkgs = with nixpkgs; [
- hlint
- #niv
- ormolu
- python37Packages.black
- python37Packages.pylint
- wemux
- ];
-in nixpkgs.mkShell {
- name = "bizdev";
- buildInputs = devpkgs;
- shellHook = ''
- echo "biz" | ${nixpkgs.figlet}/bin/figlet | ${nixpkgs.lolcat}/bin/lolcat
- '';
-}
+(import ./default.nix).env