diff options
author | Ben Sima <ben@bsima.me> | 2024-04-08 16:02:03 -0400 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2024-04-10 19:56:46 -0400 |
commit | aa5f12a5a2365a35f17becc66cf7a67fa86a4440 (patch) | |
tree | e43c059973558ea0b1687525e00789c353491460 /shell.nix | |
parent | 544d75a47e85d2b334267a43ba065bb69538ad75 (diff) |
Reorganize and update nixpkgs upstreams
This patch does a few things:
1. Switches from nixpkgs-unstable to nixos-unstable{,-small}, simply because
nixpkgs-unstable is not in cache.nixos.org, but nixos-unstable is, and -small
is the same but requires all tests to pass. So we should prefer
nixos-unstable-small, whenever possible.
2. Reorganizes the nixpkgs import code such that Nixpkgs.nix returns an attrset
of all the nixpkgs that I want to use, rather than putting other nixpkgs
branches into the main one as an overlay. This is much simpler and explicit,
but it meant I had to change a lot of usages throughtout the nix codebase.
3. As a consequence of 2, moves the overlays into separate files so they can be
re-used across nixpkgs branches.
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1 +1 @@ -(import ./Biz/Bild.nix { nixpkgs = import ./Biz/Bild/Nixpkgs.nix; }).bild.env +(import ./Biz/Bild.nix { nixpkgs = import ./Biz/Bild/Nixpkgs.nix; }).env |